Jump to content
Sign in to follow this  
HvM

Some problems with old gen CM on Win7 64-bit

Recommended Posts

Hello everyone, first of all I'm going to describe my gaming platforms, as a basis for the rest of the stuff. 1/ Notebook: Win7 64, Intel i3-2310M 2,1GHz; GeForce GT 520M; 4GB DDR3; 2/ PC: dual boot of XP SP3 32 and Win7 64, Intel Dual Core E6500 2,93GHz, GeForce GTS 250, 4 GB DDR2.

Ok, I've got no problems with running the games on my notebook or my XP-booted PC, while on Win7 on my PC CM:BB and CM:AK are stuttering and very buggy in display terms. For more info about the problem - few other games that work on my notebook or XP (like Silent Storm) also refuse to work (either graphical bugs or info about "GPU not found/compatible".

What can be causing it? My bet is that my PC GPU is unable to work properly with 64x drivers.

Share this post


Link to post
Share on other sites

Try Alt-Tab'ing/minimizing CM (CMBB, CMAK) and then re-maximizing it. I'm not sure if this needs to be done once you've reached the 3D battlefield or if you can do it beforehand. This should hopefully get the games to run smoothly instead of the 'stuttering' that you're seeing. 

I'm also not sure why your notebook is not experiencing the same problem (since they both have GeForce video cards/chips). There is the possibility that the notebook is using the Intel integrated video rather than the GeForce 520M (which should be marginally faster). If you would like to ensure that the game is running on the Geforce, then you can create a profile for the CM games within the Nvidia Control Panel (Nvidia Control Panel > 3D Settings (left-hand menu) > Manage 3D settings > Program settings tab > click 'Add' and browse for the main game executables to create profiles for them (which typically has them launch on the GeForce GPU).

As you might already be aware, fog graphics will not work in Windows 7. The effects of fog will be in place for LOS, you simply will not see the fog in the 3D battlefield. Windows Vista and newer versions of Windows officially dropped support for fog-table effects in DirectX.

Share this post


Link to post
Share on other sites

I've tried this on my notebook and nothing happens, BB and AK are working like they have always been.

But fiddling with it on my Win7 PC can help, I presume.

Share this post


Link to post
Share on other sites

So the notebook, while running Windows 7 64-bit does NOT experience any problems, correct (the playback and scrolling around the map moves fine without stuttering) ? It is only the desktop computer running Windows 7 64-bit that has the stuttering, correct ? 

I can't remember if this problem became more prominent with Windows 8 or not. At first I thought that multi-core CPUs were causing the problem by possibly trying to spread the task among the CPU cores. Setting the 'affinity' within the Task Manager would potentially address such an issue (forcing the game to run on a particular core). However it turned out that simply minimizing the game in some manner (Alt-Tab, Esc, Windows Menu key, etc.) and then re-maximizing it would get the game to stop stuttering. It appears to be some sort of issue with the DirectX commands for drawing the 3D and/or 2D screens may be causing the stuttering.

Share this post


Link to post
Share on other sites

Sorry for the late answer

 

I tried to mingle with CM on my PC Win7 and nothing changes, games still stutter. The problem is lesser if I change the resolution in the start-up setting, but still nothing changes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×