Jump to content

Recommended Posts

I believe simply Alt-Tab'ing out of the game and then re-maximizing it may get it to run at a normal speed.

 

In the past I had thought that there was an issue with 'process affinity' and multiple-core CPUs. However it appears that my guess may not have been accurate since part of the process of setting affinity involved alt-tab-ing out of the game. If you are curious to see if setting the affinity it makes any difference for you, then you can do so by Alt-Tab'ing out of the game, Ctrl-Alt-Del to 'Start Task Manager' (or however it is now termed with Windows 10). In here go to the 'Processes' tab and find the executable file name for the CM game you're running (such as 'Barbarossa to Berlin.exe', etc.). Right-click on this file name in the list and from the popup menu select 'Set Affinity'. With multi-core CPUs you will have all of the boxes typically checked ('<All Processors>','CPU0', 'CPU1', etc.). UNCHECK ALL of the boxes and then check just ONE of the CPU boxes ('CPU1', etc.). Click 'OK' and then close up the Task Manager and re-maximize your CM game. Again, it appears that simply Alt-Tab'ing out of the game and then re-maximizing it solves the issue, but you can experiment to see if the 'affinity' makes any further difference for you or not.

Share this post


Link to post
Share on other sites

Had trouble running CMBB, it was very slow on my new Windows 10 computer. Found this thread: http://community.battlefront.com/topic/113988-help/

It says: Alter the shortcut for CMBB to be something more like this:

C:\Windows\System32\cmd.exe /c start "CMBB" /affinity 1 "D:\Program Files (x86)\CMBB\Barbarossa to Berlin.exe" (Change the location of the executable to wherever you have it installed.)

Also, run it as administrator with Windows XP SP2 compatibility. [I have it in SP3]

2nd, once you get into the game (for me, all the way into the 3D map), hit your "Windows" key. The game should go out of the forefront. Alt-tab back to it, and hopefully the framerate will be good. Note that others have just been able to alt-tab. I can't, because it crashes on me every time. The windows key works fine though.

Share this post


Link to post
Share on other sites
On 9/13/2015 at 3:00 AM, Schrullenhaft said:

I believe simply Alt-Tab'ing out of the game and then re-maximizing it may get it to run at a normal speed.

 

In the past I had thought that there was an issue with 'process affinity' and multiple-core CPUs. However it appears that my guess may not have been accurate since part of the process of setting affinity involved alt-tab-ing out of the game. If you are curious to see if setting the affinity it makes any difference for you, then you can do so by Alt-Tab'ing out of the game, Ctrl-Alt-Del to 'Start Task Manager' (or however it is now termed with Windows 10). In here go to the 'Processes' tab and find the executable file name for the CM game you're running (such as 'Barbarossa to Berlin.exe', etc.). Right-click on this file name in the list and from the popup menu select 'Set Affinity'. With multi-core CPUs you will have all of the boxes typically checked ('<All Processors>','CPU0', 'CPU1', etc.). UNCHECK ALL of the boxes and then check just ONE of the CPU boxes ('CPU1', etc.). Click 'OK' and then close up the Task Manager and re-maximize your CM game. Again, it appears that simply Alt-Tab'ing out of the game and then re-maximizing it solves the issue, but you can experiment to see if the 'affinity' makes any further difference for you or not.

Great solution. Definitely works!

I had the same problem.

After pressing Windows logo key (or ALT-TAB), started CTRL+ALT+DEL.

In that click drop down arrow for "More details".

After that click on the tab "Details".

Then right click on "Barbarossa to Berlin.exe" to get the "Set affinity".

In my computer, CPU 0, 1, 2 and 3 were all checked.

I unchecked 0, 2 and 3, leaving only CPU 1 active and the game speed came back to normal!

Thanks Schrullenhaft. Great solution!

 

 

Screen Shot CMBB for Windows 10.jpg

Share this post


Link to post
Share on other sites
On 9/13/2015 at 3:00 AM, Schrullenhaft said:

I believe simply Alt-Tab'ing out of the game and then re-maximizing it may get it to run at a normal speed.

 

In the past I had thought that there was an issue with 'process affinity' and multiple-core CPUs. However it appears that my guess may not have been accurate since part of the process of setting affinity involved alt-tab-ing out of the game. If you are curious to see if setting the affinity it makes any difference for you, then you can do so by Alt-Tab'ing out of the game, Ctrl-Alt-Del to 'Start Task Manager' (or however it is now termed with Windows 10). In here go to the 'Processes' tab and find the executable file name for the CM game you're running (such as 'Barbarossa to Berlin.exe', etc.). Right-click on this file name in the list and from the popup menu select 'Set Affinity'. With multi-core CPUs you will have all of the boxes typically checked ('<All Processors>','CPU0', 'CPU1', etc.). UNCHECK ALL of the boxes and then check just ONE of the CPU boxes ('CPU1', etc.). Click 'OK' and then close up the Task Manager and re-maximize your CM game. Again, it appears that simply Alt-Tab'ing out of the game and then re-maximizing it solves the issue, but you can experiment to see if the 'affinity' makes any further difference for you or not.

Great solution. Definitely works!

I had the same problem.

After pressing Windows logo key (or ALT-TAB), started CTRL+ALT+DEL.

In that click drop down arrow for "More details".

After that click on the tab "Details".

Then right click on "Barbarossa to Berlin.exe" to get the "Set affinity".

In my computer, CPU 0, 1, 2 and 3 were all checked.

I unchecked 0, 2 and 3, leaving only CPU 1 active and the game speed came back to normal!

Thanks Schrullenhaft. Great solution!

 

 

Screen Shot CMBB for Windows 10.jpg

Share this post


Link to post
Share on other sites

You are a life saver. Setting affinity did the trick for me.

Could not get the game to load the 3D map at all (or, oddly, the editor's 2D map) after upgrading to Win X. After trying all the compatibility options in vain, I thought I had reached an end of an era.

 

My North African RobO campain lives on!

Edited by Elmar Bijlsma

Share this post


Link to post
Share on other sites

In this case, CM2 = CMBB, as far as I'm aware.

I'm not sure what sort of disc-based copy-protection the CDV versions use (possibly 'SafeDisc'), but that MIGHT be a culprit. I think the 'anthology' version (all three CM1 games in one bundle) may not have had any copy-protection. However the CM1 series games purchased individually DID have a disc-base copy-protection system.

There are 'no CD' patches of the 1.03 patch that MAY allow the game to run under Windows 10 (hopefully this link isn't an issue for BFC):

Game Copy World CM2 patches

For the Battlefront version of CMBB/CM2 you need to install all of the patches (1.01, 1.02 and 1.03) since they had different content (bitmaps, etc.) and there wasn't a single cumulative patch (however CMAK/CM3 DID have a cumulative patch to my knowledge with 1.03). I would believe that the same is true of the CDV distribution of CMBB/CM2 (i.e. - you would need to install all three patches).

The CMBB patches can be downloaded from Battlefront (the three 'Windows' patches near the bottom of this list), but these will require the Battlefront CD if used directly. You would need to use the 1.03 patch from 'Game Copy World' in order to run with Windows 10.

Share this post


Link to post
Share on other sites

I think I may have experienced something like this (and even posted about it here). So the resolution was awful.

Bought the gog.com version and it seems better. 

Share this post


Link to post
Share on other sites

This may have something to do with the version one buys (or perhaps the video card)?  I bought the CM1 games when they first were released and still run those CM1 games on my Win 7 and Win 10 machines and they look good.  

Share this post


Link to post
Share on other sites

I have a fix that works on both my Windows 8.1 and 10 laptops. No more lag, fog works and graphics look they way they are supposed to. Download a ddraw.zip from this site: https://github.com/narzoul/DDrawCompat/releases/tag/experimental It needs to be the experimental one which is the most recent as the older one didn't show fog and the graphics looked low resolution. 

1. Extract the dll file from the zip file and put in the CMBB directory.

2. Go to properties in the CMBB executable and select the comparability tab.

3. Select "Run as Administrator" and "Disable Display Scaling on High DPI Settings" (Win 8.1). The scaling options are a little different in Win 10. Go to the overide high DPI scaling behavior and select Application (this works the same as the above option in Win 8.1).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...