Jump to content

Recommended Posts

Can't play CM:RT at all since the Windows 10 upgrade.  Opens to a black screen, no error message of any sort arises. Can only close using alt-ctrl-delete.  Set it for 'run as administrator' and compatibility for Windows 8.  Not sure what's going on. Any suggestions?

Share this post


Link to post
Share on other sites

Thanks Wodin...saw your post on this issue but when I open the file location after right clicking the shortcut, I can't find the atioglxx.dll file. Is it hidden? There aren't all that many files showing.

Share this post


Link to post
Share on other sites

What video card do you have ? You may want to download and install the latest driver for it (assuming it is new enough to have Windows 10 drivers available for it).

 

The 'atioglxx.dll' file is the OpenGL driver file for ATI/AMD Radeon video cards. I haven't read the other thread regarding this, but I assume by deleting this file you are deleting OpenGL video driver support and I don't know how the game runs after that. If you have an Nvidia GeForce video card, then you will NOT have this particular driver.

Share this post


Link to post
Share on other sites

I have an NVidia GeForce GTX745, 8GB's RAM and 64 bit system. I checked the video card drivers and it says they are up to date. When I open the game I get nothing but a black screen.

Share this post


Link to post
Share on other sites

Where are you checking that is saying the drivers are 'up to date' ? You may want to download them from Nvidia and install those instead to see if they fare any better. Here's the latest 355.60 driver for Windows 10 64-bit. I would have assumed that the drivers that may have come with Windows 10 would have worked. What resolution are you currently running your desktop at ? Are you running more than one display off of this video card ? If you have more than one display, you may want to disconnect the second display and see if that helps at all or not.

 

I'm not sure if you may have messed around with the OpenGL driver before by moving a copy of the Nvidia OpenGL driver to your CMRT directory. If you did, then the file is likely named 'nvoglv64.dll' (for 64-bit versions of Windows) for Nvidia GeForce video cards. You would want to remove this file from the CMRT directory so that it isn't being used as the display driver (which would not work with the upgrade to Windows 10).  With the OpenGL driver removed from the CMRT directory, then the OpenGL driver installed in the Windows directory along with the other components of the video driver would then be used (which generally should work).

 

You can also delete your Prefs file for CMRT, which may be in your User directory for CMRT (where the scenarios and saved games would be, but in the parent folder/directory above those particular directories). This would just change the resolution that the game runs at (to 'desktop') and the settings within the Options menu (to their defaults).

 

You can download and run the OpenGL Extensions Viewer 4.36 and check your system's OpenGL support (to see if an OpenGL video driver is installed and running).

Share this post


Link to post
Share on other sites

Backup any in progress games, downloaded scenarios/campaings, mods, custom maps, etc. to a separate folder/directory outside of your game installation folder (possibly on your desktop) and UNINSTALL the game and then reinstall it. You may want to make sure that all directories associated with the game are deleted before reinstalling. The license activation typically should remain activated and you should not have to reactivate the license key after reinstalling. Once you've installed the game, then install the 1.03 patch and at that point attempt to run the game again. I'd suggest (as you were doing earlier), to use 'Run as Administrator' when running it. I'm not sure if any of the 'compatibility mode' settings are necessary, but you could enable those if you wanted to.

 

I'd also suggest downloading and installing the video driver I linked to earlier. That is the latest, official driver from Nvidia that works with your video card. The Microsoft provided driver (which comes from Nvidia) is usually a little older than the latest from Nvidia itself. When you perform the installation I suggest selecting the 'custom' one and then select the 'clean install' check box option presented a little later during the install (but it should appear before files are extracted, copied and installed).

 

When you perform the Ctrl-Alt-Del to run the Task Manager, does the listing for CMRT say '(Not Responding)' ?

 

Also, you may want to 'white list' / set an exception for the game executable within your security software so that it doesn't get interfered with. Usually such interference will result in a message from your security software and a complete refusal of the game to run (i.e. - it will not even show as a running process in the Task Manager).

 

The OpenGL Extension Viewer I linked to earlier is an utility that can show you the specific level of OpenGL support that your drivers and hardware are setup for. If the OpenGL support is only at version 1.1 or lower (suggesting 'software rendering'), then you may not have a functioning OpenGL driver installed (which is typically installed with all of the video drivers during the driver installation - it's not even an option to NOT install it).

 

If things still don't work (after reinstallation and video driver updates), then you may want to contact the Helpdesk (click on the '+new ticket' blue button in the upper right corner). You MIGHT have a licensing issue, though you should usually see some sort of error message when this occurs. This MAY require deleting your current license activation with an utility and then reactivating.

Share this post


Link to post
Share on other sites

Deleted all files, upgraded nvidia windows 10 drivers then reinstalled. Still get nothing but a black screen. When I cntrl-alt-del out it says the program is running.  May be time for help desk intervention.  Thanks for you time and efforts.  Ray

Share this post


Link to post
Share on other sites

I had the exact same problem....some graphical issue I think.  WHen I Ctnl+Tab out and hover over the game icon in the task bar, I can see what is "supposed" to be shown on the screen.  I click the icon to go back in the game and its all black.  (Also have Windows 10 Pro installed)  I right clicked the .exe and chose "troubleshoot compatability"  and followed the prompts.  Selecting compatability mode for Windows 8 and it was the same problem.  Then I went through the prompts and I chose the last time it worked...Windows 7 64 bit.  After choosing THAT compatability mode the game graphics displayed properly. All except the button pictures/icons in battle.  So theres still some fixing that needs done...dont know what to do yet.  My graphics card is a GTX980 Ti with the latest 355.60 drivers.  Everything worked perfectly until the upgrade (upgrade?) to Windows 10

 

 

Well, no sooner did I post that then a new driver was released....lol 355.81  What timing.  Downloading now will post back if the problems are fixed.

Edited by Edward_the_Surly

Share this post


Link to post
Share on other sites

After downloading the new 355.81 drivers everything works as normal again.  The scale shrunk but that can be fixed, it's working as intended.  btw, dont know if it matters or not but have been running triple screens for some time.  That might have something to do with the wonky scaling of the new drivers.

Share this post


Link to post
Share on other sites

Did anyone find a solution to this?

 

I've tried everything suggested in this thread to no avail..

 

I just bought the game so installed fresh on Windows 10 but it just goes to a black screen upon launch.

 

I'm using latest NVIDIA drivers (355.82)

 

Cheers

Share this post


Link to post
Share on other sites

Well...I finally threw in the towel and gave up. The help desk was very prompt in replying to my ticket, they sent me a small .exe file that would hopefully fix the issue of the black screen but it didn't. I did everything else first, updated my Windows 10 drivers through Microsoft, updated my NVidia driver through their website, cleaned out my directory for a new clean download, ran the small .exe file as directed....but in the end I still get nothing but a black screen after activating the game with the proper licensing key. It's frustrating because it's one of my favorite games. Battlefront's Strategic Command series all run fine as do games from other war game publishers.. It's just this game I can't get to work..

Share this post


Link to post
Share on other sites

Can BF comment on this apparent issue since new PCs are shipping with Win 10 and we all need to upgrade at some point.

 

Kevin

I do not need to upgrade, why you? Never change a running system.

Share this post


Link to post
Share on other sites

Goodness I would have a 80286 386 486 586 ... 3 laptops and partridge and pear tree at this point. Plus the wife's. I refuse to have computers outnumber people and pets in the house. :D 

Share this post


Link to post
Share on other sites

Just to point out it is not an issue for a lot of Win10 users.  Look around the forums and a number of people have upgraded with no issues.  I have tried CM2 on three different PCs, one of which came with Win10, and only one had an issue.  That was a Dell desktop with an nVidia 7XX card.  I upgraded the driver with a beta driver and it ran after that.

Share this post


Link to post
Share on other sites

Just to point out it is not an issue for a lot of Win10 users.  Look around the forums and a number of people have upgraded with no issues.  I have tried CM2 on three different PCs, one of which came with Win10, and only one had an issue.  That was a Dell desktop with an nVidia 7XX card.  I upgraded the driver with a beta driver and it ran after that.

exactly - I have been running windows 10 for almost 2 months.  All my CM games run fine and I didn't have re license anything.  Every use case is going to be somewhat specific.  If BF were to comment now it would be simply to say they don't see an issue.  However with the possible number of variables with graphics cards, drivers etc that wouldn't be particularly helpful.  Best advice is if you have an issue keep working with the helpdesk, they will work with you.

Share this post


Link to post
Share on other sites

I was just making light of holding old PCs to run games ... that's all. If the vast majority of folks upgrade to either win 10 new PCs or both with no issue that would be fantastic.

A confirmation from BFC that service tickets are rare these days as users upgrade is not required  - but would be nice to hear either way.

Kevin

Share this post


Link to post
Share on other sites

Red Thunder is the only combat mission i've bought so far, and i had tons of fun playing smaller level battles (as my computer couldn't run the bigger ones)

I got a new computer for Christmas that can run those larger battles and probably a whole lot more, and i was really excited to be able to see some huge battles, but alas, windows 10 was set up on the computer. I've updated my nvidia drivers just now and tried all sorts of compatibility options, even uninstalled and reinstalled, and yet i am always met with the black screen. I don't really want to bother the help desk, maybe you fellows might have a solution... 

I have a 17 processor and a nvidia GTX 960 graphics card. 8 gigs of ram. All drivers are up to date...

Share this post


Link to post
Share on other sites

Oh I would bother the help desk. Lots of us are running win10. The only thing I can think of is this a notebook? If so you need to use the NVidia control panel to tell it it use the NVidia card to play the game.

Share this post


Link to post
Share on other sites

I just got red thunder in the mail and installed it. While it was installing this came up \users\appdata\local\temp\temp\1_cmredthunder.zip\*.brz does not exist" I then proceeded and the installation finished. I ran the game and the screen was black. Did the installation have anything to do with this or the same windows 10 problem? i just want to play my game. 

Share this post


Link to post
Share on other sites

Wiggario - it sounds like something went wrong during the installation. The '.brz' files are the graphics files and you won't see anything on the screen without them. You may want to reinstall CMRT and see if that resolves the issue. I would suggest temporarily disabling any security software and then after the installation and activation, re-enabling it and setting 'exceptions' so that it doesn't scan the game executable/directories (in case a future signature update decides that the game executable is a virus/trojan, etc.).

Share this post


Link to post
Share on other sites

×