Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:


      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
Sign in to follow this  
Catacol Highlander

Slow map editor

Recommended Posts

I have returned to CM1 after a break of 6 years. Wonderful game. Clunky - BUT 2 player TCP works properly! CM2 is broken for me without proper replay functionality with TCP.


Anyway - the game works absolutely fine on a 8.1 platform except for the map editor. I am hankering after building a very big scenario so I loaded up an old operation from many years ago with a map 6km by 2km.


But the map editor is slow. It was always a bit slow in the old days in my experience - when trying to traverse around the editor it was always jerky on any of the 3 machines I played it on - but with my modern machine it is so slow that there is no way I can build and edit a map. Clicking on the arrows to traverse the map in editor mode results in nothing happening for 5mins or more.


If I load up a pre built map of around 1km by 1km it is a bit quicker, but by "quicker" I mean I only have to wait for 2 - 3 mins for every click of the map editor rather than 5. 



Any ideas?

Share this post

Link to post
Share on other sites

I tried out CMBB with Windows 8.1 and a Radeon HD 6870 with the 14.4 Catalyst drivers...


With Windows 7 and 8 it looks like you need to set the 'Affinity' if you're running a multi-core CPU (most people are nowadays). To do so, launch CMBB and then Alt-Tab out and then press Ctrl-Alt-Del and select 'Task Manager'. In here go to the 'Details' tab and look for the CMBB executable in the left-hand list ('Barbarossa to Berlin.exe'). Highlight it and right-click on it and select 'Set Affinity' from the popup menu. In here UNCHECK 'All Processors' (which should clear all of the check boxes) and the click on ONE of the CPU check boxes ('CPU 0', etc.). Click OK and then remaximize CMBB. Hopefully it should react a little faster in the Scenario Editor, but it will still be slow (this can potentially vary depending on the video card/chip and driver being used). This also helps with the main game. In fact, without doing this, the main game appears noticeably sluggish and unpleasant to play.

Share this post

Link to post
Share on other sites

So, Catacol, did this work? My friend and I find that if you simply Alt+Tab out, then back in, it is already noticeably faster.


I will try this suggested fix and see how it goes...nope, no better than simply Alt+Tab out-then-in. Also, it seemed to reset to ALL PROCESSORS after it was closed, then reopened.

Edited by Brent Pollock (WBRP)
typo, then update

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this