Jump to content
Sign in to follow this  
Catacol Highlander

Slow map editor

Recommended Posts

I have returned to CM1 after a break of 6 years. Wonderful game. Clunky - BUT 2 player TCP works properly! CM2 is broken for me without proper replay functionality with TCP.

 

Anyway - the game works absolutely fine on a 8.1 platform except for the map editor. I am hankering after building a very big scenario so I loaded up an old operation from many years ago with a map 6km by 2km.

 

But the map editor is slow. It was always a bit slow in the old days in my experience - when trying to traverse around the editor it was always jerky on any of the 3 machines I played it on - but with my modern machine it is so slow that there is no way I can build and edit a map. Clicking on the arrows to traverse the map in editor mode results in nothing happening for 5mins or more.

 

If I load up a pre built map of around 1km by 1km it is a bit quicker, but by "quicker" I mean I only have to wait for 2 - 3 mins for every click of the map editor rather than 5. 

 

 

Any ideas?

Share this post


Link to post
Share on other sites

I tried out CMBB with Windows 8.1 and a Radeon HD 6870 with the 14.4 Catalyst drivers...

 

With Windows 7 and 8 it looks like you need to set the 'Affinity' if you're running a multi-core CPU (most people are nowadays). To do so, launch CMBB and then Alt-Tab out and then press Ctrl-Alt-Del and select 'Task Manager'. In here go to the 'Details' tab and look for the CMBB executable in the left-hand list ('Barbarossa to Berlin.exe'). Highlight it and right-click on it and select 'Set Affinity' from the popup menu. In here UNCHECK 'All Processors' (which should clear all of the check boxes) and the click on ONE of the CPU check boxes ('CPU 0', etc.). Click OK and then remaximize CMBB. Hopefully it should react a little faster in the Scenario Editor, but it will still be slow (this can potentially vary depending on the video card/chip and driver being used). This also helps with the main game. In fact, without doing this, the main game appears noticeably sluggish and unpleasant to play.

Share this post


Link to post
Share on other sites

So, Catacol, did this work? My friend and I find that if you simply Alt+Tab out, then back in, it is already noticeably faster.

 

I will try this suggested fix and see how it goes...nope, no better than simply Alt+Tab out-then-in. Also, it seemed to reset to ALL PROCESSORS after it was closed, then reopened.

Edited by Brent Pollock (WBRP)
typo, then update

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×