Jump to content
altipueri

v3.11 crashes with quick battles

Recommended Posts

@IanL

Somehow the AI doesn't seem to like using AUTO and MIX or ARMOR ONLY Forces for the US....I can do human select and mix or armor only US no problem...I have tried different size battles as well and AUTO still crashes  

Funny I didn't notice this earlier...I play a LOT of quick battles...probably because I almost always choose to select my own force.

MIXED or ARMOR ONLY and AUTO SELECT of US forces seem to be the major trigger...HOWEVER, for MIXED and ARMOR only, as others have mentioned using HUMAN selection and then clicking the Suggestions button also causes a CTD...ONLY FOR US..Brit and Canadian appear fine.

------------------

OK, tried a couple other options..British and Canadian mixed auto works just fine...auto select for all forces (allied and axis) inf, mech, ab, works just fine..

it appears to be US AUTO SELECT MIXED or ARMOR only that crashes things...auto select map appears to have no effect on that...

weird little quirk...

Edited by grunt_GI
better definition of problem

Share this post


Link to post
Share on other sites

I had a problem with ctd with quick battles in cmbn when i tried auto picking troops but when i reinstalled cmbn, cw and mg with the combined installer it seems to work o.k.  Previously i had installed each new module separately

 

Share this post


Link to post
Share on other sites

Weird range of issues. I have the individual modules. And I can do any force selection but mixed and it works.  Annoying to be sure, BUT I usually pick my own forces, so eh...

Share this post


Link to post
Share on other sites

I'm getting the same thing as everyone else. I've had this problem for almost a year now when I upgraded CMBN and Commonwealth to version 3 back in December of 2014. Here's my post:
http://community.battlefront.com/topic/117156-311-patch-doesnt-update-commonwealth-also-getting-crash/

I also filed a ticket at that time. I recommend anyone who has this problem to file a ticket with their helpdesk, because they were/are telling me that I'm pretty much the only one getting this.

But clearly that isn't the case.

I get the crash on Armor vs Armor when I'm the attacker on US. If I do Canadian Armor vs German Armor it's fine. I'm glad I'm not the only one, but would love to have a fix.

Edited by Jingo

Share this post


Link to post
Share on other sites

Add me to the list.  Just tried to set up a quick battle for PBEM and it crashed when I hit the 'Suggestions' button, every time.  Tried it with US forces, I'll try it with the other forces when I get a chance (and I'll post a ticket).  Troubleshooting this is a very time consuming process because of the long load times every time it crashes.

Share this post


Link to post
Share on other sites

I saw your other post @user1000. Thanks for the detailed description, that is all important. I am hoping to spend some time looking to reproduce it but it is a busy time of year. I will let people know what I find but that might be some time from now.

Just to set expectations if I get the reproduceable steps some time in the next month then it will take another six months to a year for a fix to arrive. However since I and others play QBs all the time there will be a way to workaround this. I am certain.

Unless this gets collaterally repaired by some of the other QB fixes.

Share this post


Link to post
Share on other sites

I am working to hopefully find a quick fix. Unfortunately, I am finding this is an internal coding problem that may need to be patched by game designers.

 Could it be an error with just those who only have Normandy installed and nothing else?  Do the guys with market garden or vehicle pack experience or no?

Maybe the game is trying to call mix units that are not found with the normandy only game..

Share this post


Link to post
Share on other sites

I never noticed this thread before...

I have two laptops I play on, depending on what I am doing for work.  I only noticed the other day that I never installed the VP on one of the machines.  I tried an armor quick battle US vs Germans and it crashed almost immediately.  I went and tried it on the machine with VP installed and no issues.  I suspect, as was previously mentioned, that the AI is trying to select vehicles that are in the VP.  Not having the VP installed and activated is not getting error-checked and dumping the program.

Just a guess...

Edited by Thewood1

Share this post


Link to post
Share on other sites

Okay same here crashes on quick Battles

Had CMBN bare ver 1.11

Bought and downloaded the 3.00 update yesterday version is now 3.11

Nothing else installed only Normandy

Edited by crocky

Share this post


Link to post
Share on other sites

think I will purchase Commonwealth and Market Garden and see if it makes a difference

SO did the expensive fix work? Really would like to get rid of that crash to desktop error though for free. If you have not bought the modules base game should not even be calling those extra units, in QB mix......

Edited by user1000

Share this post


Link to post
Share on other sites

It seems that the problem is in relation to auto selecting US forces in armour or mixed mode (sadly setting the force selection to human and using the suggest button does not really help).  While getting the commonwealth forces does not really fix the problem it allows you to have a armour fight by selecting a commonwealth nation instead of the US.  If you do not desire the Commonwealth forces I would just wait a while longer.

Share this post


Link to post
Share on other sites

AHA! I think I have found the problem! The M7B1 HMC Priest  mentioned in the TOE is missing from the QB selection screen under single vehicle display when human picks teams. It also crashes every time EXCEPT when armor is not selected for the suggestions button. In other words if you choose all armor for a battle and click suggestions it will crash because it cannot find the M7B1 HMC Priest location to call it or some other us vehicles . I tried the suggestion button for Axis armor and it never crashes leaving me to think this is an allied armor only problem. Battlefront needs to add the M7B1 HMC Priest to quick battles, mentioned in the TOE and manual.

(I think this is the only vehicles missing but maybe others on allied side) add the vehicle to quick battles and boom problem 100% fixed. AI will now allow it to be selected when choosing armor without a crash and human can now choose it without crashing.

There is a priest mentioned but it is labeled only as "M7" Priest and comes up missing in game if you buy it.

For all these people that only have the original game and no mods try this and see for yourself. :D

Edited by user1000

Share this post


Link to post
Share on other sites

I am still having the same problems with QB's with anything American ie. Armour vs German tanks. pretty much anything to do with the "yanks" I thought the 3.12 patch was to correct this?

I have scoured the forum for help. Again any help from you guys would be great.

Share this post


Link to post
Share on other sites

You are right Kennie it is the yank tanks. I already solved the problem now battlefront must read this thread is the hard part.. Then they must do the in game fixes. It's nothing on our end..

Edited by user1000

Share this post


Link to post
Share on other sites

Yeah I thought it was fixed too. Something was fixed because I could reproduce the problem and now I cannot - I need to dig a bit more to see what is still not working.

So, you do have 3.12 - confused about your other post which seemed to say you had only v1 of the game.  OK so clear things up for me what do you actually have?  Are you saying you have at fully patched install but have only purchased the base game content?

And the defect happens when you start a QB and select automatic for the US when using armour forces.  It also happens if you press the suggest button when selecting US armour forces as well, correct?

It sucks that the fix did not work out for you - sorry to hear it.

Share this post


Link to post
Share on other sites

Yes all of us with the problem all have the base game from the CM:BN 3.11 FULL installer (already patched up and sold as 3.11 on store), and cannot get certain US armor in the quick battle. When it is called upon by ai or human during a quick battle or clicking suggestions button for armor only battle, game crashes. Check out my us armor formations only list. There is a missing Howitzer group and some others  on the US armor only side. Axis seems to be fine.

d3d870e.png

Edited by user1000

Share this post


Link to post
Share on other sites

×