Jump to content
altipueri

v3.11 crashes with quick battles

Recommended Posts

I recently upgraded to 3.11 (and thank you to whoever sent the pack of ten smaller files to download).

 

Basic scenarios seem to work, although I haven't played more than a few turns, but every quick battle causes a crash - I downloaded the set from Mark Ezra from the forum page and the new QB numbers seem to be there.

 

Is this just me?

 

 

Share this post


Link to post
Share on other sites

I have the same issue. If I choose infantry only for both sides it works just fine. Choosing mix will crash it every time.

Edited by Humbug

Share this post


Link to post
Share on other sites

I am using Juju's tweaked UI v3. Will try to remove it.

 

Just found out that it only crashes when I start a QB with the US Army as the attacker on "mix" force. Everything else seems to work fine though. 

Share this post


Link to post
Share on other sites

Yes it has nothing to do with Juju's tweaked UI or any other mods. That was just a coincidence that I tried removing that while also not using mixed force, so I edited my post.

 

After further testing it seems to have something to do with the combination of using mixed and letting the AI pick their forces. If picking their forces for them manually it seems to work just fine, but setting pick on auto or setting it to human and then using the AI suggestion will crash it every time. The instant the suggestion button is pressed the game crashes.

Share this post


Link to post
Share on other sites

Are you on a Mac or a PC ? Does your copy specifically say that it is 3.11 ? The crashing with 'mixed' forces seems to be an old bug before CMBN 3.x. What version did you 'upgrade' from ? You may want to install into a fresh, empty directory (since with the 3.11 installer you typically have ALL of the CMBN files) and see if that makes any sort of difference.

Share this post


Link to post
Share on other sites

I seem to be getting CTDs when I try to reload a QB in CMRT. I can set the parameters of the game and play a bit. But trying to reload a save of the QB after taking a break throws me straight to desktop. I'm running a fully up to date CMRT.

Share this post


Link to post
Share on other sites

I believe QB is trying to use Airborne units (in mix mode) which you may not have. I had to purchase the Market Garden add-on (to get the Airborne units) and then everything worked fine. 

 

HTH

Share this post


Link to post
Share on other sites

There's a couple of issues related to the new V3.11 one of which is the reported edited quick battle problem. I also get this crash to desktop on letting the AI pick its own force in QB.

Share this post


Link to post
Share on other sites

I'm having the same issue with 3.11 with Commonwealth.  I haven't done much testing, but I thought it was if I selected a mission parameter that the autobuy couldn't do.  For example, all I tried was an all armor tiny and it crashes every time.  I thought it might be because there weren't enough points to buy any armor.  Could be wrong.

Share this post


Link to post
Share on other sites

I get these crashes constantly and it kills so much of the game.

I get them when German army is defender, US army attack, Waffen SS defender, all sizes of battle, all selections of rarity, auto select and user select units and preview allowed or disallowed... It seems to be totally random.

Share this post


Link to post
Share on other sites

Right. I can also rule out it being a module thing as I have all the modules installed and working. But QB are still broken for me. This is so far from being acceptable, such a shame how far downhill CM has gone from the glory days of yore.

Share this post


Link to post
Share on other sites

OK there seems to be a little corner of badness going on except I cannot reproduce it.  So, lets try to figure out the magic combination that is causing problems.  I am willing to work to figure this out.  Quite frankly I have never seen anything like this and know of no open reports along these lines. 

 

Number one I need much better descriptions of what you are doing that fails.  Start with detailing every setting you are choosing and at what stage it crashes.  Please.  You do not *need* to create screen shots but I find that the easiest way.  So for example I just started a QB like this:

 

post-68949-0-67249900-1429207704_thumb.j

post-68949-0-21772800-1429207684_thumb.j

post-68949-0-85339000-1429207724_thumb.j

post-68949-0-05128700-1429207736_thumb.j

post-68949-0-04909900-1429207751_thumb.j

post-68949-0-11354300-1429207761_thumb.j

 

Share this post


Link to post
Share on other sites

I have had the crash on quick battles  Like every on else on the conditions that they describe,

CMBN,CW, MG Ver 3.11 Game engine 3

 

 

Lane

Share this post


Link to post
Share on other sites

Well, what can I say there must be some detail that you guys are not describing.  I am not getting any crashes and I am following what has been suggested here.  If you can make it happened reliably, or even a percentage of the time, please write everything down or take screen shots.  If I cannot present a reproduceable test case there is no way the devs can find the problem.

Share this post


Link to post
Share on other sites

IanL,

 

Have had it happen to me several times and just crashed twice in tests.

 

Attack (Tiny), Medium Map, (Autoselect), 30 minutes, Open terrain, France, August 1944, Clear weather, Rarity Standard

 

US Army, Armor Only, Autoselect, No map preview, no force change vs Waffen SS, Mech Infantry, Autoselect

 

Crashes as soon as I hit Okay.

 

Regards,

 

John Kettler

Share this post


Link to post
Share on other sites

Thank you for that specific set of steps. That worked find for me though. I don't think there is a coding bug herr. I have done it there times now - all good.

I think something must be specific to your machine somehow.

Share this post


Link to post
Share on other sites

IanL,

 

Happy to help. By the way, I'm running straight 3.11, with no mods of any sort. Have the complete CMBN w/wo Vehicle Pack. Have contradictory situation with last item, but I don't think it matters. Computer is late 2009 iMac 3.06 GHz Intel Core 2 duo, 4 GB RAM, 256 KB ATI Radeon 4670. OS is OS X 10.7.5.

 

Regards,

 

John Kettler

Share this post


Link to post
Share on other sites

I just got into CMBN this week and Iam also having random crashes when selecting QB. On the otherhand, no problems with CMBS, so I guess that might rule out it beeing a specific PC issue.

 

Care,

 

Mike

Share this post


Link to post
Share on other sites

I double checked and and turns out I'd bought vehicle pack but not activated it. Now that I have ALL the modules it seems to work. However, buying all the expansions shouldn't be the work around.

Edited by Huwbacca

Share this post


Link to post
Share on other sites

IanL,

Have had it happen to me several times and just crashed twice in tests.

Attack (Tiny), Medium Map, (Autoselect), 30 minutes, Open terrain, France, August 1944, Clear weather, Rarity Standard

US Army, Armor Only, Autoselect, No map preview, no force change vs Waffen SS, Mech Infantry, Autoselect

Crashes as soon as I hit Okay.

Regards,

John Kettler

This is happening for me also. Its when you choose armor Only or mix for us Army

As soon as I hit suggestion it crashes. If I just choose units myself it works.

The game dosent run that god though. Its like the game is ver heavy to proces

Edited by BTDKVega

Share this post


Link to post
Share on other sites

×