Jump to content
Sign in to follow this  
Hubert Cater

AoD v1.03.1 Hotfix

Recommended Posts

I've just posted a hotfix for the v1.03 patch in the Battlefront repository found here:

http://www.battlefront.com/index.php?option=com_remository&Itemid=314&func=fileinfo&id=3079

Please install the v1.03 patch first prior to applying this hotfix as the hotfix is not all inclusive.

The hotfix will need to be extracted first from the ZIP file and then installed via the installer by double clicking the hotfix EXE installer file.

The hotfix includes the following CTD corrections:

- fixed a controlled unit movement error (patrat618)

- fixed a rare submarine movement error when the sub is in Silent mode and passes near hidden enemy Destroyers that may interrupt the movement path (rjh1971)

Hubert

Share this post


Link to post
Share on other sites
Do I need to install the hotfix before doing a turn? It would seem to me that you would have to?

Yes, simply close the game, install the hotfix, and then reopen the game and continue as you normally would as the hotfix is backwards compatible with v1.03 saved games.

Hubert

Share this post


Link to post
Share on other sites

Hi Hubert.

Seems I am to stupid to install the hotfix.

I followed your instructions, but instead of installing the exe just makes a new folder of AOD inside my AOD installation with the exe.

What am I doing wrong?

The hotfix is definitly not installed, as I keep getting file read errors from opponnts turns.

Share this post


Link to post
Share on other sites

Hello -

Installed the hotfix today - silent sub movement into hidden enemy destroyers was causing the game to freeze - and now I get a new error during the AI's next turn.

[09/24/2014 9:43:48; 6.1.7601; 1680x1050x32(0); v1.03 AoD] FAILED(animate_recon_spotting): Segmentation violation

[09/25/2014 4:57:07; 6.1.7601; 1680x1050x32(0); v1.03.1 AoD] FAILED(animate_recon_spotting): Segmentation violation

[09/25/2014 5:09:24; 6.1.7601; 1680x1050x32(0); v1.03.1 AoD] FAILED(animate_recon_spotting): Segmentation violation

Game crashes at this point.

Is there a way to uninstall the patch and go back to 1.03? I can't seem to find an uninstaller for the hotfix. Is there a way - command line option, renaming and replacing a file, whatever - to roll back?

If there's anything I can do to help resolve let me know.

Caustic

Share this post


Link to post
Share on other sites

Hi Caustic,

Sorry to hear about the trouble.

We've also come across this bug and unfortunately it would also appear in the pre hotfix version so no advantage to rolling back.

This is fixed on our end and I could release another hotfix as needed.

Can you send me the turn that is causing this crash and once I confirm that the current fix on our end resolves this I'll release a new v1.03.2 Hotfix.

Please send to support@furysoftware.com

Thanks,

Hubert

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...