Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
76mm

Camera won't stop rotating!

Recommended Posts

Really strange.  I have no idea what could be causing that.  How many other see this - and cannot account for it with food or pets :D

Share this post


Link to post
Share on other sites

The issue is not caused by sticking, food or pets.

 

I have had the same issue for a long time and BF tech support has never found a solution.

 

Sometimes, manually rotating in the opposite direction works. Sometimes reboot of the whole computer must be done as a last resort.

Share this post


Link to post
Share on other sites

I've installed CMRT on a new computer and this problem is back, but is even worse--now instead of spinning the map shoots off at a high rate of speed.  None of the tips posted in this thread fixes it.  Honestly, this just sucks, it is hard to get motivated to fire up this game when you know that when you do you'll have to spend ten minutes trying to get the camera to behave.  Doesn't anyone have a solution? I've got Win10 64bit.

Share this post


Link to post
Share on other sites

If you have a new computer, does that mean you have an old keyboard/mouse lying around to swap with the new item to see if it corrects the problem? If you're talking a laptop then things get more complicated. I've had to replace my mouse/keyboard four times over since I've been playing this game.  And I've had to pay close attention to the surface the mouse is moving over. Hardware wears out - especially if you're in the habit of eating sandwiches over the keyboard while playing.

Share this post


Link to post
Share on other sites

It is a desktop; the keyboard and mouse are both new--three months old.  I have a spare keyboard, but not a mouse (actually I use a trackball rather than a mouse).  I will  try swapping the keyboard, but I had this problem on my old computer even as I went through about three keyboards, so I don't think the keyboard is the problem.

Share this post


Link to post
Share on other sites

I've noticed that it seems like the camera will not allow itself to be over the map--it scoots off at high speed until it is not over the map any longer, then stops.

I'm extremely frustrated that I seem to be one of the few people that have this problem, despite being on two separate computer systems with very little in common between them.

Share this post


Link to post
Share on other sites

@76mm

I'm thinking maybe your problems are due to your trackball. Very few seem to use those, and you're getting a technical problem that very few people see. Try switching the trackball for a regular mouse for some time and see if that solves the problem.

Edited by Bulletpoint

Share this post


Link to post
Share on other sites

@Bulletpoint Yeah, I thought of this too--in fact the trackball is the ONLY common element between the two computer systems (second trackball, but same model).  I've been busy with work lately and haven't been able to monkey with this (or had time  to play the game), but I will give it a try.  Although I hate the though of giving up my trackball!

Share this post


Link to post
Share on other sites

Well, it's not the trackball...I unplugged it a few days ago and plugged in a new mouse.  Things worked fine for a couple of day but now the problem is back.  Very very frustrating, game is basically unplayable.

Share this post


Link to post
Share on other sites
On 20/8/2016 at 9:18 AM, 76mm said:

Well, it's not the trackball...I unplugged it a few days ago and plugged in a new mouse.  Things worked fine for a couple of day but now the problem is back.  Very very frustrating, game is basically unplayable.

That's the worst, when you think you finally solved problem with your computer, you happily play your game for a couple of days, then suddenly it's back.

My last idea is to try remapping all keys that are involved with turning the camera to something else, then see if it solves the problem. If not, then BF helpdesk is your last hope.

Share this post


Link to post
Share on other sites

shortly after my last message, I did what you suggested with the hotkeys...so far no reoccurence, but I've been hesitant to post because I'm sure that as soon as I post it will happen again.

Share this post


Link to post
Share on other sites
On 6-9-2016 at 6:34 AM, 76mm said:

shortly after my last message, I did what you suggested with the hotkeys...so far no reoccurence, but I've been hesitant to post because I'm sure that as soon as I post it will happen again.

I've had the same problem. Another thing is that from time to time the game automatically zooms in, 20x. The only remedy is to exit the game and start it up again.

Edited by Aragorn2002

Share this post


Link to post
Share on other sites

I've recently acquired a laptop with Windows 10-64 bit on it ( away from home for long periods for work :( ) and have experienced this a couple of times now.

Quit game and reboot has always worked for me so far, but have no idea what causes it. :angry:

Share this post


Link to post
Share on other sites

I still have this problem after all these years, using different computers and different input devices.  I basically hardly play anymore because most times I start the game, I cannot get the camera to stop spinning.  Except when it doesn't.  Very very frustrating...

[EDIT]  After some experimenting, I've had some success in trouble-shooting the problem:

1)  If I remove the hotkey.txt file from the userdata folder, the problem stops.

2)  If I keep the hotkey.txt file in the userdata folder, but delete the alternative (ie, non-standard) camera control options, the problem DOES NOT go away.

3)  If I keep the hotkey.txt file in the userdata folder, but comment out the camera control lines, the problem stops.  

Not having a hotkey file or camera control hotkeys is not doable for me, but hopefully I can narrow it down further...

Edited by 76mm

Share this post


Link to post
Share on other sites

Yes, this problem has been around for years. It still happens to me with 4.0. I am able to solve it by using Hotkeys to move the screen in opposite directions of the spinning. When that fails, reboot the computer.

Share this post


Link to post
Share on other sites

I found this is the v4 upgrade readme file. I don't know if it would apply to this.

Quote

* SCREEN EDGE PAN TOGGLE: Tired of trying to fine tune a camera position and then messing it up by touching the edge of the screen with the cursor? Using the hotkey ALT-E you can disable camera panning by touching the screen edge with the mouse cursor.

 

Share this post


Link to post
Share on other sites
1 hour ago, Sgt.Squarehead said:

randomly tap the default move camera keys, one of 'em (nobody seems to know exactly which) will stop it.....It's a small ritual you have to go through to keep the BF Wargods placated.  ;)

Sometime this works, sometimes it doesn't.  I think it is somehow connect to the hotkeys file, but haven't figure out exactly how.  I have not had this problem in a few weeks now, so maybe the evil map-spinning demons have been exercised from my computer.

Share this post


Link to post
Share on other sites
3 hours ago, IanL said:

Just out of curiosity what graphics cards do those that see this problem use?

That's the thing, I've had the problem on two different computers, with different video cards.  This computer has an NVidia GeForce GTX 960, my other computer also has a Geforce, but I forget which model.

Share this post


Link to post
Share on other sites
14 hours ago, 76mm said:

That's the thing, I've had the problem on two different computers, with different video cards.  This computer has an NVidia GeForce GTX 960, my other computer also has a Geforce, but I forget which model.

Well perhaps a pattern will emerge. I have not hit the problem since switching to a GeForce 760 from an older HD Radeon 6770. I was hoping that everyone with the problem would have the same brand of graphics card.

With only two people (but four graphics cards) reporting it seems not.

Share this post


Link to post
Share on other sites
On 9/8/2017 at 7:23 AM, 76mm said:

That's the thing, I've had the problem on two different computers, with different video cards.  This computer has an NVidia GeForce GTX 960, my other computer also has a Geforce, but I forget which model.

Have you changed mice? And do you play full-screen or in some kind of windowed mode?

Share this post


Link to post
Share on other sites

×