Jump to content
Sign in to follow this  
FGM_Enven

Keyboard issue.

Recommended Posts

First off, game rocks.

One issue, WASD are not mapping, nor are any of the other keyboard commands for camera/zoom. Kind of bizarre since I can see the hotkeys file is correctly configured by default, as well, going to Options and making the pertinent changes to what is already mapped (Its mapped for WASD keys already, which is odd) to be doubly sure and it is still not working.

This is out of the box CMRT, nothing more nothing less.

I am using an ATI card, Intel I7 Processor, 16GB of memory and Windows 7.

Share this post


Link to post
Share on other sites

Weird. The same thing happened to me at first. I was messing with the different control settings, FPS an RTS. My WASD and QE keys did not work at all. I quit and restarted a couple times, switched control settings back and forth, and eventually selected Standard, and the keyboard controls worked again.

Very weird bug in there somewhere, perhaps.

Share this post


Link to post
Share on other sites

Was having the same problem, tried a whole bunch of solutions but turns out the fix was hilariously simple

I just went with the default install settings so what it did was install all the game files in a "Combat Mission Red Thunder" folder inside of a new battlefront folder in program files (x86)

Meanwhile it installed a "Combat Mission" folder into my original battlefront folder in Documents

All I had to do was move "Combat Mission Red Thunder" into the same folder as "Combat Mission" like so

ITmKwZh.png

And it was fixed, could use all my hotkeys, hope this helps

Share this post


Link to post
Share on other sites

Ok thats just bizarre. Thanks for all of your assistance! Kind of weird because I tried tinkering between settings repeatedly, didn't work. Tried the folder swap and ta-da! Works.

Thanks!

Share this post


Link to post
Share on other sites

Thanks, I tried switching to FPS controls first thing and found that the WASD keys didn't do anything. I was wondering if anyone at BFC had played an FPS since Doom:D

Share this post


Link to post
Share on other sites

Had this issue also. I moved Red Thunder from My Documents\Battlefront\Combat Mission

to My Documents\Battlefront and it worked fine after that. The game is installed on another drive.

Share this post


Link to post
Share on other sites

**FIXED**

So other than moving the folder to the CM folder as stated (Which I think causes an override for the Hotkeys config file); I tinkered with all three control setups in the Options section, repeatedly then started up a battle, worked great.

Share this post


Link to post
Share on other sites

Okay, had same issue...but I only had to move the hotkey text doc (from x86/RT/Data folder) to the "Documents" CMRT folder, and the keys worked. So maybe you don't need to move the whole RT folder over.

Share this post


Link to post
Share on other sites
Okay, had same issue...but I only had to move the hotkey text doc (from x86/RT/Data folder) to the "Documents" CMRT folder, and the keys worked. So maybe you don't need to move the whole RT folder over.

Thx for that. That did it for me also.

Share this post


Link to post
Share on other sites

I forgot to report back on this thread...all sorted. I had two hotkey docs in the Documents/Battlefront/CMRT folder...one in the User Data folder, one "outside" that folder. Don't know how...but anyway, delete done and used Phil C.'s hotkey fix and all is OK.

Share this post


Link to post
Share on other sites

Just had the same problem here too!

Solved by moving my hotkey file from my base game location and replaced the one in the my documents folder, within my RT user data folder.

Thank god for the search tab eh! All working well now.

The strange thing is, is that I had the same problem with FI/GL but it sorted itself out when I changed back from FPS to standard setting... Something for the devs to get their head around I guess :)

Share this post


Link to post
Share on other sites

Thank you guys for the solution..I had no idea what I was doing wrong. I simply copied the hotkey file in the data area of the main game to the Documents/Battlefront/Combat Mission/Red Thunder/User Data and every thing works perfectly now. Thanks again.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...