Jump to content
Sign in to follow this  
Paulverisor64

Can not initialize graphics display error

Recommended Posts

I've been using my laptop as my game computer. It has always worked correctly when projected to a 24 inch Monitor.

Yesterday I upgraded from a 24 inch Monitor to a 32 inch flat screen TV. (Samsung 550 series). Upon clicking on the Combat Mission icon I get the error "Could not initialize graphics display. Required 1024x768, 32 bit color"

Now I can't get into either Combat Mission Battle for Normandy or Combat Mission Fortress Italy.

In the past I have been able to play over the 32 inch TV using a desktop PC.

Could you help me get back up and running again?

A couple other notes.

I've tried this with the DSUB and HDMI connections.

I tried installing Combat Mission Normandy on my other PC that I had no issues with and it came up with the same error message. (This would be on a 50 inch Panasonic TC-P50U50 it originally was the Samsung.)

Share this post


Link to post
Share on other sites

Paul, what version of Windows do you have? Is there any way you can check what resolution your TV is set once you connect your laptop? Basically right click on the desktop and there should be either "properties" or "screen resolution" option (it all depends on your Windows version).

If your TV is for some reason set to the 720p mode (1280x720 resolution) - it could be the cause of the error. As I understood Combat Mission requires at least 768 vertical pixels.

However the Samsung 550 series TVs are advertised as full HD, which should imply they have 1080p resolution (1920x1080)..

Share this post


Link to post
Share on other sites

Hi Simas,

I am running Windows 7 Professional.

The interesting thing is that both of my TV's now refuse to play Combat Mission. The one that I'm most concerned about is the one that is in conjunction with my laptop. I know for a fact that this TV used to be able to play Combat Mission with my desktop computer. However that same desktop computer that played Combat Mission on the older TV now is getting the identical error in trying to open up Combat Mission on the new TV.

I can verify that I am running 1920 by 1080 on both computers. When you input over to it by using the remote the resolution numbers flash briefly. Also my desktop resolution sizes still read 1920 by 1080.

There are a couple anomolies that I'm witnessing.

1) The old TV's display is not crisp, there is distracting ghosting.

2) When I set up both TV's with PC's the initial display was a little outside of the edge boundaries all around. I made adjustments with the TV remote to have everything line up the display to the boundaries correctly. I don't recall having to do this before. Perhaps this gives a non standard resolution?

I'm actually glad this isn't working properly with the new TV as it most likely means it isn't my laptop combined with the TV that is the issue. Most likely this is a settings related error. The other good thing is that my new TV is under full warantee support so I can get the phone calls rolling shortly.

If anyone knows what I'm running into I'd appreciate hearing how you've got past this issue. If I can find a solution in the mean time I will gladly post what was causing the issue as well as the resolution.

Share this post


Link to post
Share on other sites

I've found out what was required to get back up and running.

I should have Google searched prior to posting.

Solution: Right-click on the launching shortcut for CMBN and select "Properties" from the popup menu. In here go to the "Compatibility" tab and there will be a section in the middle of the tab labeled "Settings". At the bottom of of this section checkmark the box next to the text that says "Disable display scaling on high DPI settings". Click 'Apply' and then 'OK'. Hopefully this should now allow the game to run.

Share this post


Link to post
Share on other sites

Thanks for this, Paul. I just spent about four hours or so doing everything I could think of to get CM to work at 1080p on a 42" Sharp I just got for my birthday. I did a bunch of searches and just happened to catch this thread on my last try (and right as I'd finished writing up a big thread about the issue that I was getting ready to post). Your solution worked for me. I now have CMBN, FI, and RT running as they should. I was really getting worried I wouldn't be able to get them to work on the big display. 

 

I am gonna post a new thread in the Black Sea forum with an easier to find search title and tags with this info. All of which will be credited to you of course. Thanks again, you saved my @SS!

 

 

 

Mord.

Share this post


Link to post
Share on other sites

I've found out what was required to get back up and running.

 

I should have Google searched prior to posting.

 

Solution: Right-click on the launching shortcut for CMBN and select "Properties" from the popup menu. In here go to the "Compatibility" tab and there will be a section in the middle of the tab labeled "Settings". At the bottom of of this section checkmark the box next to the text that says "Disable display scaling on high DPI settings". Click 'Apply' and then 'OK'. Hopefully this should now allow the game to run.

Thanks. Just had the same problem, and your post helped me.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...