Jump to content
Sign in to follow this  
PhilM

Shader fix for a MacBook Pro

Recommended Posts

Hello guys, this is my first post on the forums: a request for help! I have looked at other posts on the shaders issue, but they don't seem to answer my two questions fully.

I have fully patched and upgraded versions of CMBN plus Cw module v2.0, and CMFI. They are both set to the same (max) graphics settings, etc. CMFI works fine; CMBN (now) does not. Each time I start CMBN the 3D/Game graphics do not work correctly, certain parts of the screen (all units, hedges, buildings) turn a bright pink. I can get rid of this in-game by using Alt&r, turning off the shaders; I presume it is one of the max graphics settings which turn them on again each time I start the game.

My two questions:

1. Do I need - for my MacBook Pro installation - to use the fix of copying the CMFI shader files to CMBN to solve this, so that CMBN works like it used to, and like still CMFI does?

2. If the answer to the above is yes, where in CMFI on a Mac can I find the Data folder which contains the shader files to copy over? As a relatively new convert to Macs, I'm not as familiar with the file structure as I would be for a pc, but:

- in my standard installs, the two application folders do not contain any (visible) data sub folders, only the app files themselves, the manuals pdfs, and - for CMBN only - sub folders of battles etc.

- Macs hide system files by default; using the method of opening the top menu bar "Go" command and holding down the Alt key I can then see and explore the "Library" folder. But the Library/Application Support folders for the CM titles do not contain the data sub folder (only a couple of text files for each game); nor does the Containers folder, used by some apps, have any CM entry. Where should I be looking on a Mac? Or is it a different problem / solution for a Mac?

Thanks in advance for any help you can give me.

Share this post


Link to post
Share on other sites

If you right click (handy if you use a pc mouse) on the app to show 'Contents' and drill down to get to the 'Resources' folder with the 'Data' folder inside.

This how it looks with the demo anyway...

Screen-Shot-combat-mission.jpg

screenshot-cm.jpg

Share this post


Link to post
Share on other sites

Wicky,

Thanks very much for this: told me something I didn't know how to do! And I have now found the Data folder.

But now left with another problem. The Data folder contains some large .brz files - so do I need to extract the relevant two shader files from (one of?) the .brz files? And if so, how do I do that with no rezexplode for the Mac?

Do I need to get at an extracted version of the shader files via the hotfix that was issued for CMFI (even tho that now works OK)?

Share this post


Link to post
Share on other sites

It appears that Softpedia still has the CMFI 1.00 Hotfix up.

Download this and extract it (.zip). All of the Mac files are in the '_MACOSX' folder. You will need to know what graphics chip your MacBook is running, ATI (AMD) or Nvidia. If it is ONLY Intel, then these shaders do not apply. The two shader files ('._bumpmapping.frag' and '._bumpmapping.vert') need to be copied to the 'Data' folder within your App bundle (as shown above by Wicky).

Share this post


Link to post
Share on other sites

Schrullenhaft,

Thanks for the further clarification; my MacBook Pro has Intel graphics so seemingly no good for me.

Just to be sure I did download and try both sets - separately! - but they had no effect, still had my pink hedges etc.

I did not find a '_MACOSX' folder in the extracted zip file? Just four folders, two for the two sets of shaders and one each for QB maps and floating icons? Not sure if the absence of the Mac folder makes any difference, as I assume from your comment re Intel graphics which I have that even Mac-specific shaders (if there is such a thing?) in a Mac folder would not work anyway for me?

Any chance of a fix that works for me? Don't know how big a proportion of the user base my position represents!

Share this post


Link to post
Share on other sites

I'm not sure why you don't see the '_MACOSX' folder, unless Apple hides the others or something. For the shader files do you see the entire file name ? If so are you seeing something like '._bumpmapping.frag' and '._bumpmapping.vert' ? The PC ones are named 'bumpmapping.frag' and 'bumpmapping.vert', just slightly different. If necessary, you may want to look at the files from a command prompt with Terminal.

According to Phil, the Mac programmer, the shader code is inquiring to the drivers what they can support. So it appears the Intel drivers aren't being quite truthful with what they can do. I'm not sure how different the shader code is in CMBN 2.0 compared to CMFI. I would have assumed it would be mostly the same.

The two shader files will NOT work with Intel video to my knowledge. They consist of some more advanced shader calls that somewhat newer/more-powerful video cards support. ATI and Nvidia may have different ways of supporting these calls, so there are separate shader files for each. I don't know where Intel falls on this spectrum, especially with the Apple driver. Which MacOS are you running ?

Share this post


Link to post
Share on other sites

I'm running OS X 10.8.2.

I've tried again extracting the zip file contents - simply by clicking on it, and so using Apple's built in default zip extractor - and get the same results (unsurprisingly!). No Mac folder, and the shader filenames are as you describe the PC versions: 'bumpmapping.frag' etc, not the '._bumpmapping.frag" version.

Don't know why I cannot see the Mac folder, if it is being extracted; don't get any sort of error message or hiccup in the extraction process.

Afraid I don't know how to use terminal to see if I can find the files, but will look into that.

Thanks again for the help so far.

Share this post


Link to post
Share on other sites

Having had a look at the Mac help, I've tried using the 'ls" command in a terminal window, for the folder created by the zip extraction.

I placed the zip file itself in a newly created separate folder, to try and isolate it from everything else and everything else from it. The extraction creates a new sub folder, and puts the extraction contents in it. I specified the path for the list command in Terminal by dragging the new sub folder from a finder window to the Terminal window

The listing in Terminal is exactly the same as I can see in finder, ie no Mac folder. So unless the extraction is placing the Mac folder somewhere else (?), still no idea why I don't appear to have it. But I'll keep looking.

Share this post


Link to post
Share on other sites
Guest

The files with the preceding dot are what shows up in Windows. There aren't PC and Mac versions of the shader files - you can use the bumpmapping.frag and bumpmapping.vert you've got now in the Mac version.

You're not seeing the Mac/MACOSX folder because that's a Windows thing. The zip file, unzipped on Mac, will just contain your files. All of the files contained in the zip file will work in both the PC and Mac versions.

The improved shaders MAY work with an Intel card, but very likely will not.

Let me know if you've got more questions.

Share this post


Link to post
Share on other sites

Wicky,

Thanks also for your latest suggestion and link above. I haven't yet used the link contents method, but have tried another way to show invisible files in Finder. Using Command&F with a finder window open, the default search criteria are "Kind - is - Any". By changing kind to other, and then selecting file visibility as the criterion from the list offered, the second set of criteria become a choice of three: visible / invisible / visible or invisible.

Using this method I can see invisible files, but still cannot see the extracted Mac folder, nor the Mac-named shader files?? But I'm not sure if I cannot see them because they're not there (!) or this method still would not show them for some reason?

Share this post


Link to post
Share on other sites

Phil,

Thanks for that information - I posted my response to Wicky without having read yours; my response would have been different if I had seen it first.

At least your response restores my sanity a little, in that the reason I cannot find any more extracted files, visible or invisible, is because they aren't there!

Given that I had already tried both version of the shader files with my Intel graphics Mac and not had any success, I think I'm stuck for now at least with needing to turn off the shaders with Alt&r each time I play. Not ideal, but I can live with it.

Share this post


Link to post
Share on other sites

One more thing to look at is your graphics settings. If you are looking at "About this Mac" and it says you have Intel graphics, there are a couple of possibilities.

If you have the small screen MacBook Pro, then Intel graphics is probably all you have and the shaders probably won't help.

If you have a 15" or 17" MacBook Pro, you should have Intel on board graphics and a separate high performance graphics card. If so, in the Energy Saver in System Preferences, there will be check box at the top to enable automatic graphics switching. If it is checked, it will only use the high end graphics when necessary, so that when you are not doing anything impressive and just looking at the Apple logo menu "About this Mac", it *may* show Intel because that's what it's using. You can click on More Info and then System Profiler and then Graphics and it will list what you have - both the on board and then separate (AMD 1GB in my case). You can also (assuming you have the switching button) uncheck that and it will always use high performance graphics. The button is there to reduce battery consumption. Some games and programs also are not able to make the graphics switch from basic to high performance. CM is one of these according to their mac tips. You'd want to uncheck the box before starting up to make sure it's running the high performance graphics at startup.

I downloaded the hotfix from that link and placed those two ATI files in my Z folder and the shaders then worked. Not sure I like them though as the bocage hedges look a little odd with them on. There was no MACOS folder. The mac just shows you the correct sets of files.

Hope that helps and forgive me if this is all old news to you but it might answer some of the questions.

Share this post


Link to post
Share on other sites

For what it's worth, I could not see a "_MACOSX" folder when I extracted the folder on a machine running OS 10.6.8. Running the third party app Wicky linked to, as well as Secrets did not make the folder visible either. I did see it when I extracted the .zip file on a WinXP machine.

I copied the"_MACOSX" folder from the XP machine to the OSX machine successfully, the sub folders are visible, however none of the files are. The folder has a size of 8KB, so something, albeit very small, seems to be there.

I am a recent Mac convert and am looking to purchase the OSX version of the game, but this gives me pause. If the file linked to above was the hotfix issued by BFC , how did Mac users apply it if the OS makes the relevant content invisible by default? If I didn't have access to a WinXP machine I would have no idea anything was there at all.

Share this post


Link to post
Share on other sites

Oh hell, you guys are too fast. It looks like Phil rode in on his white horse while I was still pecking at the keyboard.

There aren't PC and Mac versions of the shader files - you can use the bumpmapping.frag and bumpmapping.vert you've got now in the Mac version.

Thanks Phil, that was exactly what I needed to know - it looks like Saint Nicholas will have to bring along a copy of OSX flavored CMBN after all!

Share this post


Link to post
Share on other sites

Ultradave,

Thanks for your suggestions. My MacBook Pro is the 13'' version, and so has only the built in Intel graphics without a separate graphics chip (and so doesn't have the energy saver option either).

Given this relatively limited graphics capability I did wonder how the hardware would cope with the nice max graphics settings, but it does seem to work very well generally. And indeed it does run CMFI on max settings fine; it is just this shader issue with CMBfN.

Not sure why the latest incarnation of each game would be different as regards the use made of of the shaders; given that the CMFI shaders seem to solve problems for some in CMBfN, it would seem more logical if either both games, or neither game, caused this problem (or not) with my Intel graphics at those settings?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...