Jump to content
Sign in to follow this  
Asmodeus

v.1.11->2.0 Can't use NUMPAD to select commands from command panel anymore

Recommended Posts

Hi there folks.

Just yesterday I fought a quick match with CMBN 1.11. and the Numpad controls did work for selecting commands.

Today I upgraded to 2.0 and thought to give a try and to get to see how is the new and shiny engine working, but didn't get to play too much because I need to get my Blitzkrieg Command panel working again before trying.

Only keys that are working:

/...Previous Command Panel

*...Next Command Panel

I did try to enable and disable Num Lock:

disabling turned Numpad keys to camera control

enabling disables camera control possibility, but doesn't 'enable' anything in change.

Any suggestions or am I missing something that's new in version 2.0?

Share this post


Link to post
Share on other sites

Gave a try assigning numpad keys directly to hotkeys.txt -file under

// These keys are relative to the button position in the displayed command panel and are used only when a Command Keys Direct is not specified for a given command

Command Keys Default

removing also keys specified under Command keys direct, in vain.

The default keys for selecting commands in Command panel relative to one's position were UIO-JKL-M,. (whose idea was that layout).

But now I can't even make numpad keys to work by forcing!

So like I've heard someone say: "Fix or do sumfink!"

btw. "the other" game (or should I say all of them) works with numpad-keys like they ought to.

Share this post


Link to post
Share on other sites

Not being angry or anything but I'd like someone to chime in here and take me through this holding my hand.

I think I'm talking now about the Relative system I'd like to use with NUMPAD keys (like I could before 2.0 upgrade).

Like I told on the second post I tried to bind the keys, but that didn't do any good.

NUMPAD keys ARE working, if I 'disable' them I can use them to control view point in-game.. oh, I did mention that already in the OP.

BTW. thanks for caring, I did already a fresh install *grin*

I just don't seem to understand how the keys are supposed to be bind to use Relative system with NUMPAD keys.

BTW no.2. Do I read the 2.0 manual right that the NUMPAD keys should be the default choice for controlling Unit Commands?!

Share this post


Link to post
Share on other sites
Not an expert in ANYTHING related to hotkeys, but have you loaded the v2.01 patch?

Yes, just a day ago I did, and made the installation also. Today I've just tried to get the NUMPADs to work like they used to, now when they're not working at all.

Share this post


Link to post
Share on other sites

What seems to be now, after the fresh install of the game and patching it up to 2.01 (from 1.00), that the Relative System should be working by default. According to "CM Engine Manual v2.0" the keys are UIOJKLM,.

These keys are now working as in Direct mode, why? I don't know.

Why the hell the Game can't have the possibility in-game to change what System to use with the keys.

There's three different text-files inside Data-folder and not a single one is giving a desired outcome when changed to default key mapping (= changed to hotkeys.txt -filename).

Share this post


Link to post
Share on other sites

Didn't know about the numpad - I was reading the manual and realized how good/fast this numpad solution could be. I wanted to tried it and numpad does not work for issuing commands. While UIOJKLM do the same I prefer having the numpad since it's way more intinuitive for me.

Devs, how can we enable numpad if we can at all or is this broken now?

Share this post


Link to post
Share on other sites
This has been reported as a bug. CMFI (1.0 & 1.01) also has this problem.

I do NOT know when a fix will be released to address this issue.

Thank you for bringing this out Schrullenhaft.

Fingers crossed.. then :)

Share this post


Link to post
Share on other sites
This has been reported as a bug. CMFI (1.0 & 1.01) also has this problem.

I do NOT know when a fix will be released to address this issue.

Thank you for the heads up . saved me some time meddling with the settings.

Share this post


Link to post
Share on other sites

Steve has informed me that the NumPad Relative Hotkey system was discontinued with version 2.0 and it was intentional. It never really worked in a manner that they desired and it was decided to stop support for this system. However the manual was not updated with this change, so the Engine manual still mentions this system.

I'm not sure why the U,I,O,J,K,L,M and , and . still work for the Relative Hotkeys and the NumPad does not. It's possible another patch may remove the Relative Hotkeys all-together.

Share this post


Link to post
Share on other sites

I'm buffled and don't understand why it didn't work - I was never able to try it so I don't have first hand experience. I'm against such a decision but there's nothing I can do now. ;(

Share this post


Link to post
Share on other sites

What, noooo. For me it did a world of difference.

That style was quick to use and wasn't even hard to master.

What does the game have now. Why I have this feeling I don't care to go and find out.

I just can't see a reason why a multitude of choices would be worse than having a single? solution like it is? now?

Thanks Schrullenhaft for the heads up.

Share this post


Link to post
Share on other sites
Asmodeus, so if you were using it have you noticed any problems with it back then?

No.

And for the worth of six characters: only problem is that it can't be used anymore.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...