Jump to content
Sign in to follow this  
Ales Dvorak

Strange shadows

Recommended Posts

After upgrade to 2.0 (mac) I noticed strange shadows on roofs of some buildings.

http://dl.dropbox.com/u/3470914/Shadows%201.png

http://dl.dropbox.com/u/3470914/Shadows%202.png

http://dl.dropbox.com/u/3470914/Shadows%203.png

http://dl.dropbox.com/u/3470914/Shadows%204.png

Then I thought that may be something wrong with TaL buildings, but no, same thing with stock graphics.

http://dl.dropbox.com/u/3470914/Shadows%20-%20Stock%20graphics.png

How many suns do we have now? ;)

About shaders. After upgrading CMFI shaders look great in the game, but not so great in CMBN (same settings).

http://dl.dropbox.com/u/3470914/Shaders.png

Stock g.

http://dl.dropbox.com/u/3470914/Shaders%20-%20Stock%20graphics.png

No shaders

http://dl.dropbox.com/u/3470914/NO%20Shaders.png

Share this post


Link to post
Share on other sites
Guest

What kind of video card do you have?

We'll likely be coming out with "improved" shaders, like we did for CMFI, that should make things like shadows, etc., look even better for newer (newer than 4-5 years or so, in most cases) video cards.

Share this post


Link to post
Share on other sites
What kind of video card do you have?

We'll likely be coming out with "improved" shaders, like we did for CMFI, that should make things like shadows, etc., look even better for newer (newer than 4-5 years or so, in most cases) video cards.

Mini mac, NVIDIA GeForce 320M. But shaders in CMFI work ok.

Share this post


Link to post
Share on other sites
Guest

Thanks.

Z: were you using the improved shaders from the CMFI hotfix?

Ales: I'll take a look.

The neat thing about the shaders is that a pretty wide array of improvements / fixes can be made, and in most cases all you gotta do is drop the new shader files into a Z folder. So hopefully we'll get this stuff sorted out quick.

Share this post


Link to post
Share on other sites
Ales: I'll take a look.

The neat thing about the shaders is that a pretty wide array of improvements / fixes can be made, and in most cases all you gotta do is drop the new shader files into a Z folder. So hopefully we'll get this stuff sorted out quick.

Good news. Thanks...

Share this post


Link to post
Share on other sites
Thanks.

Z: were you using the improved shaders from the CMFI hotfix?

Yeah, in CMFI I saw a great improvement when using the hotfix, so I was a bit surprised when it didn't look so good in CMBN.

So can I copy the CMFI hotfix into the Z folder for CMBN then? I'm not at my home PC so I can't remember if there's a hotfix file in there or if it came as a patch.

Share this post


Link to post
Share on other sites
Guest

The hotfix was just a bunch of files. There were shaders for different video card types included, that you could just drop in your Z folder. Actually, yeah, the CMFI hot fix shaders *should* work with 2.0 - I don't think I made any structural changes that would render it inoperable. Give it a shot and let me know.

Share this post


Link to post
Share on other sites
Guest

Thanks Ales. From your screenshots it looks like an improved shader, a la CMFI, would help. Were you using the hot fix shaders in CMFI?

Share this post


Link to post
Share on other sites
The hotfix was just a bunch of files. There were shaders for different video card types included, that you could just drop in your Z folder. Actually, yeah, the CMFI hot fix shaders *should* work with 2.0 - I don't think I made any structural changes that would render it inoperable. Give it a shot and let me know.

Thanks for the info Phil - I will try this out in a couple of hours when I get home and let you know. Unless someone else beats me to it of course!

Share this post


Link to post
Share on other sites
Thanks Ales. From your screenshots it looks like an improved shader, a la CMFI, would help. Were you using the hot fix shaders in CMFI?

After I read Zatoichi post I took a look in CMFI "z" folder. NVIDIA shader folder was still there.

I removed folder and result was:

http://dl.dropbox.com/u/3470914/Without%20NVIDIA%20shaders%20map.png

Then I put folder back and result was:

http://dl.dropbox.com/u/3470914/WithNVIDIA%20shaders%20map.png

Then I duplicated NVIDIA folder and put it into CMBN "z" folder and.. voila, much better. :)

http://dl.dropbox.com/u/3470914/With%20NVIDIA%20shaders%20map.png

All good for now, but strange shadows on the roof are still there....

Share this post


Link to post
Share on other sites

Ha - great stuff Ales! I'll be doing the same as soon as I can make up an excuse to leave work early!

I've not seen the roof shadow thing, but I've only had a very quick look so far. I'll see if I get the same issue and report back.

Share this post


Link to post
Share on other sites
Ha - great stuff Ales! I'll be doing the same as soon as I can make up an excuse to leave work early!

I've not seen the roof shadow thing, but I've only had a very quick look so far. I'll see if I get the same issue and report back.

I'm glad we solved this for now. Please report about shadows on the roof...

Share this post


Link to post
Share on other sites
Guest

Cool. Thanks Ales. Let me know how it goes, Z. Sounds like it'll work. Good thing I made it that way in the first place, I guess. :)

The roof shadows are an issue with the way that the shadow mapping in the game works. It may be fixable, but it would be part of a much larger change.

Share this post


Link to post
Share on other sites

I have noticed shadow issues in 2.0 as well. When I move the camera sometimes the shadows tend to disappear and then re-appear (GeForce 460 GTX). I can probably make a quick video to explain this better if needed.

Share this post


Link to post
Share on other sites
Cool. Thanks Ales. Let me know how it goes, Z. Sounds like it'll work. Good thing I made it that way in the first place, I guess. :)

The roof shadows are an issue with the way that the shadow mapping in the game works. It may be fixable, but it would be part of a much larger change.

Right back home, copied the bumpmapping.vert and .frag files over from my CMFI Z folder, and the shadows look great again - cheers!

I did see the odd shadow effect as per Ales' pictures, but it didn't look so striking on my screen (to me at least):

https://dl.dropbox.com/u/105376648/roof_shadow.jpg

Edit - hmmm - Paint seems to have done something weird to some of the textures when I've pasted the screenshot - they look much better on my PC!

Share this post


Link to post
Share on other sites
Is there a link to this shader hotfix for CMFI so us without that game can import it into CMBN please?

They were released as a downloadable zip file as a hotfix back in August, but then rolled out as part of CMFI patch 1.0.1 as far as I recall - I think the hotfix was then taken down.

I only have the NVIDIA ones - you can PM me if you also have an NVIDIA card and I can send them to you (they're tiny), or you can wait for BF to release another hotfix. If you have an ATI card then I'm afraid I can't help!

Share this post


Link to post
Share on other sites
Got them, thanks guys!

I have an Nvidia card indeed. So the folder inside the zip goes into the Z folder like a normal mod?

Yes, unzip and put new shaders Nvidia folder into "z" folder.

Done.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...