Jump to content

Recommended Posts

Hi,

could anybody rund SC WWI with Windows 8 64bit?

I applied the latest patch and it cannot be started.

It raises the message

"current system does not support a 0x0x32 resolution"

Any ideas how to fix this?

Share this post


Link to post
Share on other sites

What is your resolution and color depth settings for Windows 8 ? You are running the game from the 'desktop' correct (I'm not sure if it will appear as a tile in Metro). For some reason it seems to be read as 0 x 0 at 32-bit color (by the game or Windows, I'm not sure).

If you open up the 'SC2.ini' file in the SC WW1 directory, what are the following settings ?:

#ORIGINAL_SCREEN_WIDTH=

#ORIGINAL_SCREEN_HEIGHT=

#WINDOW_WIDTH=

#WINDOW_HEIGHT=

#FULL_SCREEN=

#BIT_DEPTH=

#VIDEO_ACCELERATION=

You MIGHT want to reapply the 1.06 patch, but this time launch it by right-clicking and selecting "Run as administrator" and see if that makes any sort of difference.

Did you upgrade to Windows 8 64-bit or is this a new install ? What was your previous OS ? With most OS upgrades you should get a request from the game to reactivate the license key (since the copy-protection system is assuming you are running on a different computer with a different OS). Did this happen for you ?

Share this post


Link to post
Share on other sites

I reinstalled the patch with administrator rights and now the SC2.ini

looks like this

#ORIGINAL_SCREEN_WIDTH= 1920

#ORIGINAL_SCREEN_HEIGHT= 1080

#WINDOW_WIDTH= 1920

#WINDOW_HEIGHT= 1080

#FULL_SCREEN= 0

#BIT_DEPTH= 32

#VIDEO_ACCELERATION= 1

The game launches now but after the first screen it is not possible to start a game or load a saved one. Only the exit works.

I did a new install and installed the game also new.

I did get a licenencens request and that worked.

I did now switch my grafix card, hope I have not to license it again

since I might run out of licenses in this case.

I also installed Battlefront at win 8. The game starts and can be played (it seems to be much slower)

But when using the full screen mode I get an error:

"draw to map screen: dirextx failed: dderr_exception"

Share this post


Link to post
Share on other sites

Changing the video card or a number of other hardware items in the computer WILL force you to reactivate. If you haven't contacted the Helpdesk yet, then you may need the gsClean utility to delete the current activation so you can reactivate.

If you run out of license activations we can also add one at the Helpdesk (we need your license key in order to do that).

Running in the 'Full Screen' mode WILL generate the:

"draw to map screen: dirextx failed: dderr_exception"

error. I'm not exactly sure what in Windows 8 is causing this. It's possible that a patch may be needed to fix this particular issue and I'm not sure how complex that may be since this is a DirectX error.

Regarding the save game error, you may want to try launching the game by right-clicking and selecting "Run as administrator from the popup menu and see if that allows you to load save games and create them. However, I'm going to guess that this may not work.

Share this post


Link to post
Share on other sites

Sorry to hear the trouble and I believe I know what the error is and how this has been changed since the Windows 8.1 release.

Can you try running the game NOT in full screen mode as that should get you up and running as a temporary work around for now.

This can be changed in the SETTINGS dialog in game in the main menu screen.

Hubert

Share this post


Link to post
Share on other sites

Hi

If you go to the game's folder, there should be a file in there called sc2.ini

In that, you can change the setting for full screen to the following:

#FULL_SCREEN= 0

Save and close, and that should hopefully get you up and running!

Bill

Share this post


Link to post
Share on other sites

Thanks Templer! I was able to use that to resolve the issue, though I also needed to change the bit_depth variable in sc.ini from 0 to 32.

 

Sorry I didn't reply for two years Hubert - I think the email notification must never have come to me!

 

Looking forward to playing some SCWW1 again!

Share this post


Link to post
Share on other sites

×
×
  • Create New...