Jump to content
Sign in to follow this  
GDog

CMBB Display issues on new system

Recommended Posts

Hi guys, been away from CM1 for a long time, trying to get it up and running on my updated system. I've been trying in vain to use the search function on the BF forums, so new topic time.

Win 7 64bit

EVGA GTX 670 4gb

2x LCD displays, primary at 1920x1080, secondary at 1680x1050

Installed CMBB special addition, and it only offered me 1280x1024 resolution. If I'm correct, CMBB has a max resolution of 1600x1400, any ideas how to get that option?

Moving on, once I select the 1280x1024 resolution I launched the game and it ran fine.

Today, I star the game and first it opens on the second monitor, but I cannot click menu buttons with mouse. I can hover over them and the cursor interacts with the buttons (button changes in apperance slightly) but clicking gets no response.

Close game, restart and this time it doesn't display anywhere. The game is running, theres an icon on my taskbar but I can't get the game to display.

I've been messing around with compatibilty modes - windowed vs maximized - deleting pref files, all sorts of fun stuff, but to no avail.

Thoughts?

Share this post


Link to post
Share on other sites

Hi GDog, If your display's vertical pixel limit is 1080 or 1050, then you aren't going to get the game run higher than that, and certainly not 1400, I'm afraid. Delete your prefs file again, set your desktop to the primary display and maximum resolution it will go to (whilst still showing all your desktop) then restart the game. The game will then run through available resolutions, starting with your current desktop (if it can match it) else it will cycle down through all others it thinks it can fit through your computer's display card (within the game's own preset limitations - which in this case sounds like the 1280x1024 it offered you). At least, my DVD versions of CM1 games all act this way. Don't know about later download versions of these games but mine don't offer wide-screen, so you either have to let your computer stretch the image (bit ugly) or force your computer's display adapter to not stretch it and live with a black band down each side to fill the gap to the edge of your screen (looks slightly odd after being used to a wide-screen, but gives a nicer, sharper picture).

There could of course be other issues specific to your graphics-card...

My top tip for searching the Forum for specific queries: use Google instead - just type into Google your specific query like the following four words: CMBB screen resolution battlefront

Share this post


Link to post
Share on other sites

Believe me, I've googled this to death. Of course the 1024 is the limitation here for my 1080 monitor, should have realized that to being with!

Maybe I've never run these games at a higher resolution, and just being away from them for so long I just forget how the game looks?

Thanks for the reply.

Share this post


Link to post
Share on other sites

Correction, my monitor supports 1600x1200. I just tried setting the monitor to that resolution, deleted the CMBB pref file and still don't get any option more than 1280x1024.

Will keep playing with it.

*EDIT*

Hurrah! I got it to work. Should mention I am also using ULTRAMON to manage multiple displays, which I think is helping take control over CMBB in this case.

Set monitor resolution to 1600x1200 in both desktop settings and in NVIDIA control panel.

Set startup properties in CMBB shortcut to run maximized

Set UltraMon display properties for CMBB to run 1600x1200 and maximized on Monitor 1

delete pref

start CMBB and first resolution offered is 1600x1200

exit game, reset desktop to 1920x1080

start game to test, and after a little flicker, it launches at 1600x1200

exit game and find it has moved a few desktop icons that were not within Win 7 Fences (another amazing desktop application I might add) shifted to where they would be if desktop was at 1600x1200.

To fix that I'll just have to make sure all shortcuts are assigned to a Fence, or just keep them in the middle of my display, or not worry about it.

Share this post


Link to post
Share on other sites

Yay you found it!

Sorry, if I sounded silly - I only mentioned Googling for battlefront threads and contents because you'd only mentioned using/struggling with the forum's own search system and so I assumed that you therefore weren't aware that forum entries are also open to internet search.

Hmm, admittedly I'm on Windows XP, but if I reset my desktop from where it usually is (at 1280x1024) down to 1024x768, to be lower than my game (which was also already set up at 1280x1024) my game then won't start as normal but goes through the list of resolutions from the reduced desktop downward - i.e. the game won't run at a resolution higher than the desktop. This doesn't surprise me (it's as I expected it would act) - I'm just offering it because its different to your experience. Thus I assume either Win7 is different or UltraMon is interfering (in a good way) in the process. Either way, it therefore might be plausible to assume that one can tell Win7 or UltraMon that when you launch the game it does so using a certain set of compatibility rules that end when the game ends, thus preserving your normal desktop. Probably a no-go but maybe worth a try looking at advanced settings somewhere? Just thinking out loud......

Share this post


Link to post
Share on other sites

I would like to get my Samsung laptop screen to show the black bars as well. My max res is 1600 x 900 on a 17" screen, Nvidia GForce GT 540M. I have tried different things and I will do the google search, but thought I would try a post here as well. Thanks in advance anyone.

Share this post


Link to post
Share on other sites

Streety, I think UltraMon is doing a big part of the work. It adds a couple tabs in shortcut properties, similar to compatiblility rules I think. I see where you are going in your last post, will poke around and see what settings I can find.

Share this post


Link to post
Share on other sites

1) GDog - Hope there's something hidden there for you.

2) Blazing88's - I've got a Samsung netbook (which admittedly only has an integrated intel graphics card, but the concepts might be a similar-enough arrangement to your laptop). On that I had to find the display settings' "aspect ratio" options which then gave me the options to alter the "panel fit". There were 3 options - and I found that by changing from the default "Full Screen (no border)" to the option "center image" (the other option was "maintain aspect ratio"), the games run centered on the screen instead of stretched. On some bigger machines these graphics options instead come under "image scaling" of the graphics card, on others that have both integrated graphics and a dedicated graphics chip sometimes this basic screen option is still managed by the integrated graphics settings. Either way, you probably need to find an option somewhere in your display settings called something like "center image" or turn off one called "image stretch".

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...