Jump to content
Sign in to follow this  
Odin

Problem with shadows

Recommended Posts

I'll do that now - but I have to say that my machine can handle a small scenario like 18 platoon on BEST/BEST.

Results shortly.

Share this post


Link to post
Share on other sites

Here you go:

2 images from same scenario on Balanced/Balanced.

BalancedBalanced-Shadows1.jpg

BalancedBalanced-Shadows2.jpg

BTW - I have done some tests and there is no discernible loss of Frame rate with 1.10 on my Mac (I think I just had other apps open during the original test)

Share this post


Link to post
Share on other sites
In Game use ALT-W hotkey.

Just tried that in-game .... Locked up my MacBook Pro so bad, I had to use power OFF key to recover ... :eek: :D

Regards,

Doug

Share this post


Link to post
Share on other sites
Guest
I'll do that now - but I have to say that my machine can handle a small scenario like 18 platoon on BEST/BEST.

Well, there's a difference between handling it, and producing an optimal play experience and image quality, especially for resource-intensive pieces like shadows that can use a little room to run.

Best, again, *forces* the game to try and use the highest-quality everything - models, textures, settings - speed of the game be damned. Which, ironically, can have a deleterious effect on the end result. *Actual* image quality (what ends up on your screen) usually does better when there's a balance, due to the way that every piece of the puzzle - VRAM, RAM, HDD, CPU, and GPU - has to juggle resources. It's way more intense, and resource-intensive, than one might imagine.

Long story short, Balanced can produce almost exactly the same image quality as Best (especially for pieces that matter like close-up models, or are very resource-intensive like shadows), but you're not forcing your machine to try for it *every single frame* which can be a stretch for anything but the highest-end hardware. Hell, when I'm just playing for fun I usually run the game on Fast and rarely notice any difference in image quality, except for things like distant trees.

Just... a side note, really. :)

Here you go:

2 images from same scenario on Balanced/Balanced.

BTW - I have done some tests and there is no discernible loss of Frame rate with 1.10 on my Mac (I think I just had other apps open during the original test)

Hmm. Thanks. That is a bit too dark. And thanks for the frame rate feedback. Other apps can make a huge difference, especially on OSX.

Just tried that in-game .... Locked up my MacBook Pro so bad, I had to use power OFF key to recover ... :eek: :D

Regards,

Doug

You turned shadows off, and it locked up your machine?

Share this post


Link to post
Share on other sites

You turned shadows off, and it locked up your machine?

That's an understatement .... :D

Clicked ALT-W and my whole screen started flashing ON and OFF rhythmically in bunches of square graphics blocks, some of which were solid black. I hit ALT-W again and it returned to normal, however it seemed to be going through an entire screen memory refresh. Once that was done it settled down.

I tried it again with same results, however, this time the second ALT-W didn't do anything to return screen to normal and I was locked up solid. I had to use power OFF button and reboot.

Haven't tried it since as I don't want to screw up my file system with lock ups. :P

Regards,

Doug

Share this post


Link to post
Share on other sites
Guest

Whoa. Sorry to hear that. Sounds like your video card can't handle the default shadow method.

As you may or may not know, Apple drivers prevaricate (to put it nicely) about card capabilities and make it seem like all cards on a given version of OSX have the same basic capabilities, when some don't.

If it was honestly telling the game it couldn't handle a certain thing, we could turn that off automatically or use a different method. The game is built to do that, but unfortunately when drivers give us bad information it makes it very difficult to work around.

Shoot. Well, I'll see what I can do.

Share this post


Link to post
Share on other sites

Shoot. Well, I'll see what I can do.

Don't worry about it Phil.... :)

I don't need it... :D

I was just trying to help out by doing some testing for folks who have shadow issues on Macs. My MacBook Pro runs CMBN (CW) just great. I have ALL graphics options on BEST and play with trees ON and all other ALT options ON (ie: smoke). She runs smooth as glass... ;)

To be frank, I don't know if shadows are ON by default as I've never really noticed, so I don't know whether it was trying to turn them ON or OFF when I selected ALT-W and locked up.

Anyway, if you ever want a "beta" tried to see if it fixes the ALT-W on my system listed below, I'd be happy to try it for you.

Regards,

Doug

Model Name: MacBook Pro

Model Identifier: MacBookPro5,1

Processor Name: Intel Core 2 Duo

Processor Speed: 2.53 GHz

Number of Processors: 1

Total Number of Cores: 2

L2 Cache: 6 MB

Memory: 8 GB

Bus Speed: 1.07 GHz

Boot ROM Version: MBP51.007E.B06

SMC Version (system): 1.33f8

NVIDIA GeForce 9600M GT:

Chipset Model: NVIDIA GeForce 9600M GT

Type: GPU

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 512 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0647

Revision ID: 0x00a1

ROM Revision: 3437

gMux Version: 1.7.3

Displays:

Color LCD:

Resolution: 1440 x 900

Pixel Depth: 32-Bit Color (ARGB8888)

Main Display: Yes

Mirror: Off

Online: Yes

Built-In: Yes

Share this post


Link to post
Share on other sites

Hi Phil,

Glad that the shadow images helped.

I am so pleased that you think that you have solved the 'blockheads'! It is the one bug that really grates with me. I can deal with the shadows, the flashing icons etc... but those damn low polygons at close range - yuk.

I have taken on board what you have said about the effect of running CMBN at Best compared to Balanced. All I can go on is my experience whilst playing CMBN, and I have to say that the game always looks best when the settings are at least set to BETTER on my machine. With larger maps there is a deterioration of frame-rate no matter which setting I use (there is a slight improvement on faster settings but graphically a lot worse).

I ran the game at BALANCED when I first got hold of it but have subsequently found that the best balance between performance and graphics is usually at a higher level than this. This is what I meant by my 'machine can handle it' - I probably really meant: 'I can handle it'.

Naturally - this is purely subjective (and probably flies in the face of logic).

Share this post


Link to post
Share on other sites

I'm having the same problem since I got the CW module. Here's a picture:

pEftj.jpg

My system is using Windows XP on a AMD Phenom II X4 955 CPU, 4 gigs of ram (though only 3 used due to the 32bit limit), and a pair of Radeon HD 4890's in crossfire configuration. In the screenshot I'm using balanced/balanced settings and I also tried disabling crossfire and only using one graphics card but to no avail.

Share this post


Link to post
Share on other sites

I don’t post much, but i just have to jump in here and say that after updating to 1.10 my shadows went darker also. I was quite happy with the way they were in 1.01.:D

ez

Share this post


Link to post
Share on other sites

Phil, how is it going with solving the shadows issue? I also thought you might like to know that I am getting flickering overhead icons with the Axis forces as well as Allied.

Share this post


Link to post
Share on other sites

Also have issues with overly dark and stripey shadows.

OSX Lion

Chipset Model: AMD Radeon HD 6970M

Type: GPU

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 2048 MB

Vendor: ATI (0x1002)

Device ID: 0x6720

Revision ID: 0x0000

ROM Revision: 113-C2960K-152

EFI Driver Version: 01.00.507

Share this post


Link to post
Share on other sites

I don't know if it's related or not but I just updated my Nvidia drivers and my whole screen seems to have darkened. I've tried several Nvidia settings to no avail. Both CMA & CMSF run just as they used to though.

Like some others I too switched the shadows off years ago.

Any suggestions on what may be darkening my screen are very much appreciated.

Share this post


Link to post
Share on other sites

Thought I'd add to the thread, but it's nothing new we don't know about the Radeon cards. I'm using a Radeon 5800 with recent drivers, and I'm having the exact same problem with the shadows. Unfortunately I've had to play the game with the shadows off.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...