Jump to content
Sign in to follow this  
Odin

Problem with shadows

Recommended Posts

The shadows on my armoured vehicles have been playing up since I installed the CW module. I'll admit in my excitement to install the new module I didn't remove the mod folder. I have done this subsequently though and run the CW installation again but it doesn't seem to make a difference. I am running the game on an AMD Radeon HD 6630M 1GB Graphic Card.

I don't think the photo below is illustrating the full effect of it, but in game it is quite off putting.

CMNormandy2012-03-0616-20-42-05.jpg

Share this post


Link to post
Share on other sites
Guest

Depending on the angle of the sun those shadows could be correct, or as "correct" as a game can make them. What's the problem with them?

Share this post


Link to post
Share on other sites

It doesn't show up in the last photo too well, so here's another taken at 9am 'game time'. I understand that there are likely to be some early morning shadows at this time of day, but it's just the grainy nature of the shadows which are not right. The shadows will also completely disappear on occasions when I move the camera about, almost like they've been switched on and off.

CMNormandy2012-03-0617-57-32-68.jpg

On the above photo it shows up more on the tank to the left.

CMNormandy2012-03-0618-13-46-21.jpg

Whilst on the bottom photo you can see the effect most strikingly on the Tigers and half tracks

Share this post


Link to post
Share on other sites
Guest

Ahh, I see it. Yeah, those are pretty common problems with shadows in extreme (angle-wise) lighting conditions in most games.

Unless you use volumetric shadows (which don't work well for outdoors scenes) or a lot more shadow passes (which would slow the game down exponentially) it's pretty tough to get around them at certain times of day in-game.

Can you try lowering your model quality slightly and see if that helps things any?

Share this post


Link to post
Share on other sites

Just tried it on 'balanced' in the graphics options (photos above taken on 'best' settings) but it doesn't make a difference. I had a look back at videos I made of version 1.01 and I didn't seem to be having problems with shadows.

Share this post


Link to post
Share on other sites

Sorry to go on about this shadow bug. But surely this can't be right? Anyone have any ideas as to how I can resolve the issue?

CMNormandy2012-03-0721-26-33-50.jpg

Share this post


Link to post
Share on other sites

I have the same problem since the module... The shadows become dark.

I make an installation/desinstaltation of the base game + module to resolve the probleme but it didn't work...

I use ATI radeon HD 5800 series

Share this post


Link to post
Share on other sites

C3k I'm using the AMD Radeon HD 6630M. Do you have any ideas as to what I could do?

Phil I'll try updating the driver to see what happens.

Share this post


Link to post
Share on other sites
Guest

Thanks guys.

And this problem wasn't showing up in the base game?

Share this post


Link to post
Share on other sites

No I didn't have any problems in the base game. As well as adding some weird and grainy shadows the game also also seems to exaggerate shadows now.

Share this post


Link to post
Share on other sites

I'm getting the same problem. Very dark striped shadows on vehices - at a distance some vehicles look completely black. Also dark patches on objects like haystacks.

Definately did not have this in 1.01. But I recall thinking something was wrong with shadows in 1.00.

Nvidea gts250 with latest drivers.

Share this post


Link to post
Share on other sites

I have this as well, and just put it down to the scenario I was playing being set during high noon- i don't notice this during other lighting situations thus far. It does seem exceedingly dark in strange places when it shows, though.

I am on an ATI 5990, updated drivers, Windows7 64bit. Haven't tried the Mac side of things yet.

Share this post


Link to post
Share on other sites
Guest

Thanks guys. I'd be interested in knowing how the Mac side looks when you get a chance.

Share this post


Link to post
Share on other sites

I get this too since I installed CW. I'm running a Radeon HD 5970 with Catalyst 12.3 installed. Interested to know if there's a fix so thought I'd give this thread a bump.

Share this post


Link to post
Share on other sites

Wait, there are people who don't get the striped, flickering shadows? It's been like that for me since CMSF. I just gave up on it and turn them off from the start. I did notice that after the CW patch they are much darker than before, but are still absolutely atrocious, especially when vehicles are moving. It's too bad, as the environment and infantry shadows are nice and make the game look a lot better.

Radeon HD 5770 with 12.2 drivers (same with all previous drivers AFAIK)

Share this post


Link to post
Share on other sites
In Game use ALT-W hotkey.

Doh !!! :D

Thank you ... I never realize that ...

I was looking in the options screen under those settings ...

Regards,

Doug

Share this post


Link to post
Share on other sites
Guest

Look at the line of shadow in the road. That's a picture of a vehicle *entirely* in shadow. Still overly dark, though. Definitely not what I'm seeing on my card.

If you put the settings on Balanced / Balanced in that same shot, how does it look? Best / Best or thereabouts is going to push your card very hard. You're basically telling the game "try to make *everything* in this scene as nice as possible". That's trees, grass, distant model and terrain quality, everything, even stuff you may not particularly care about.

You could end up with better-looking overall images *and* faster frame-rates by letting the game manage things a bit. If your card can handle it the game will still push image quality higher, but in cases where your card needs extra room, settings like Balanced / Balanced will help the game make that decision.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...